An R package to automatically fetch data from the UK Parliament API. Ironically, Hansard data is not yet accessible through the API. To explore all available data see http://www.data.parliament.uk/. Help on the API itself is here: http://api.data.parliament.uk/help/.

Like the UK parliament API, this package is a work in progress. Additional functionalities will be added to the package as they are developed in the API. The most up-to-date documentation for this package will always be available at http://ropengov.github.io/hansard and at https://docs.evanodell.com/hansard/.

To install from CRAN run:

install.packages("hansard")

Or, if using the pacman package:

pacman::p_load(hansard)

To install the development version run:

install.packages("devtools")
devtools::install_github("evanodell/hansard")

Using hansard

For an introduction to hansard, please see the vignette. If you are unfamiliar with APIs this introductory course is useful.

API calls with console input

Previous versions (<=0.3.4) of hansard included options for console-based inputs to call data and interact with the API. This feature has been removed from subsequent versions, and is available in the https://github.com/evanodell/hansard-console package. There are no plans to submit this to CRAN, and it is not being actively maintained.

Disclaimer

This package is in no way officially related to or endorsed by the UK Parliamentary Data Service.

Acknowledgements

This package is part of rOpenGov. It was written by Evan Odell.